惟云 惟云

maven构建项目时@Override错误的解决办法

in 学习笔记 read (596) 文章转载请注明来源!

@Override报错:因为jdk版本问题。@Override是jdk5就已经存在了,但是不支持接口的实现,认为这不是Override而报错,jdk6及也上版本修正了这个Bug。

项目左下方出现一个感叹号,JRE 显示的是 1.5 版本。解决方式有两种,
(1).一种是配置 pom.xml.
(2).一种是配置 settings.xml
方式一:settings.xml 配置

打开 %maven%/conf/settings.xml 文件并编辑它(%maven% 表示 maven 的根目录) :

<profiles>
  <profile>
    <id>development</id>
    <activation>
      <jdk>1.7</jdk>
      <activeByDefault>true</activeByDefault>
    </activation>
    <properties>
      <maven.compiler.source>1.7</maven.compiler.source>
      <maven.compiler.target>1.7</maven.compiler.target>
      <maven.compiler.compilerVersion>1.7</maven.compiler.compilerVersion>
    </properties>
  </profile>
</profiles>

找到 <profiles> 节点,并添加如上配置(本机 jdk 1.7.0_79 版本,配置时修改成你本机的 jdk 版本)。保存并关闭。重启 eclipse 即可。
重启后配置生效。

方式二:pom.xml 配置

在 <build> 节点添加如下配置(本机 jdk 1.7.0_79 版本,配置时修改成你本机的 jdk 版本):

<build>
  <plugins>
    <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-compiler-plugin</artifactId>
      <configuration>
        <source>1.7</source>
        <target>1.7</target>
      </configuration>
    </plugin>
  </plugins>
</build>

配置完成后,需要执行一次更新项目配置的动作。选中项目 --> 右键 --> Maven --> Update Project(eclipse luna 版本,helios 或indigo 版本选择 Update Project Configuration)

jrotty WeChat Pay

微信打赏

jrotty Alipay

支付宝打赏

文章二维码

扫描二维码,在手机上阅读!

学习笔记
发表新评论
博客已萌萌哒运行
© 2021 由 Typecho 强力驱动.Theme by YoDu
前篇 后篇
雷姆
拉姆